Announcement

Collapse

Seven Wiki Available

Please check out our wiki available at:

http://www.californiacaterhamclub.com/wiki7
See more
See less

Weber Question

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Weber Question

    My car is running but the number one cylinder header is cool/luke warm to the touch after running the motor for a couple minute.

    Has anyone ever dealt with this issue before? and if so was it from a clogged carb jet or something else.

    My next motor is going to be fuel injected.

    Scott

  • #2
    Scott

    I'm still planning on stopping by your place Thursday, late afternoon early evening.

    Feel free to call.

    Doug

    Comment


    • #3
      When you say it is cool after running for a few minutes, are you referring to idle only, or at cruise? Have you confirmed that it is not a spark issue?

      Thanks,
      John
      Westfield SEiW
      2.0L Duratec
      Throttle Steer

      Comment


      • #4
        New update:

        Looks like I've got a problem with my motor, the oil is milky in color but even with a dry sump system I dont think the oil should look like it does, also have some foamy oil and a little water under the valve cover. It's new motor built by William S., not sure if I have a bad head gasket or something more terminal.... but will find out soon enough when I flush the oil system out and take the oil pan off....
        Here is the compression 150, 145, 120, 120

        Doug came over and was a lot of help with suggestions on how to improve the outlook on my motor.

        Comment


        • #5
          Keep sluggin, it's worth it in the long run. We look forward to seeing you at an event one day soon.
          Chris
          ------------
          A day you don't go a hundred is a day wasted

          Comment

          Working...
          X