Announcement

Collapse

Seven Wiki Available

Please check out our wiki available at:

http://www.californiacaterhamclub.com/wiki7
See more
See less

Voltage at TPS

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Voltage at TPS

    Just finishing the wiring on my Duratec 2.0. I've got a problem with the voltage reading at the throttle position sensor on my SBC/MBE fuel injection.

    As I understand it I should be gettting a .3xx volt reading, and I am getting 5 volts. Big difference. Anyone got any ideas? I've e-mailded SBE, but haven't got an answer as yet.

  • #2
    Not sure about teh SBC/MBE but normally you have 3 wires on the TPS. one has permanent ground, one has permanent 5V and the 3rd one changes voltage between about 0.3V and 4.5V depending on throttle position.

    If this wire shows 5V no matter which position then I suggest the ground connection is bad or possibly the resistor element inside the TPS is broken.

    Gert

    Comment


    • #3
      Gert is right.

      The TPS is just a potentiometer. Somewhere along the line you will have a voltage between 0-5 volt.

      Your ECU needs to be aware of the following:
      Min/Max voltage to expect.
      Voltage at closed throttle (idle).
      Voltage at full throttle.
      Please note that in some cases full throttle can give close to 0 volt reading, while closed throttle gives a close to 5 volt reading.

      All these can be setup at the driveway with your engine hooked up to a laptop.

      /Magnus "Have you hugged your ECU today?" F.

      Comment


      • #4
        TPS

        Thanks for the information. I still haven't got an answer from SBE, but I suspect they will say something similar. I'm kind of (very) lost regarding ECU's and their ins and outs. Looks like I'd better start looking for someone with a laptop.
        Rich

        Comment


        • #5
          I have a laptop and some (Pectel) ECU knowledge. Tell me if you need any help.

          /Magnus F.

          Comment


          • #6
            Continuing TPS situation

            I got answers to my emails to SBD, but they said that I should get in touch with MBE, as that is their area. I've e mailed them twice. No answer. Has anyone had dealings with MBE? Are they usually so unresponsive? I'm sitting here with a car I can't drive, register, or even finish. Oh well, I guess i can work on making it look better.

            Comment


            • #7
              tps

              Rich,

              Did you measure the voltage of the other two TPS wires?

              Is it possible that the 5v is getting fed back into this wire? Can you disconnect this one wire from the harness and then measure it (probed to chassis ground)?

              You can also remove the TPS from the throttle bodies and move it by hand to see if any of the three wires on it change readings.

              Note: it is possible to install upside down/backwards.

              Cheers,

              Tom
              Tom "ELV15" Jones
              http://PIErats.com

              Comment


              • #8
                I found MBE pretty responsive, but that was in regard to getting stuff delivered, not how to use it. It is racing season just now and as I remember it their website asks for some money if you want support, so...
                Chris
                ------------
                A day you don't go a hundred is a day wasted

                Comment

                Working...
                X